Close

World-Class Support

Perfect Photo Suite 9 not showing in Adobe Photoshop CS5

Perfect Photo Suite 9 requires Cs6 or higher for optional host application plugin compatiblity. You may still use the software as a stand alone. See full system requirements here.